News/Software Requirements V2.0

From GMOD
Revision as of 23:58, 24 January 2011 by Clements (Talk | contribs)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search


Software Requirements, Ver 2 Proposal

The proposed revisions to GMOD's software membership requirements have been approved.

The Version 2 requirements are:

  • Meets a common need
  • Useful over time
  • Configurable and Extensible
  • Open source license for all users
  • Interoperable with existing GMOD Components
  • Commitment of support
  • Publicly archived mailing list (new)
  • Publicly accessible code repository (new)

The revised requirements were discussed at the September 2010 GMOD Meeting, and on GMOD Mailing Lists. Not surprisingly, these uncontroversial revisions were approved in both forums (and even on Twitter).

Thanks for your help and input,

Dave Clements
GMOD Help Desk


Posted to the GMOD News on 2010/12/21